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Quelle: http://www.sembs.rv.bw.schule.de/dokumente/frontpagetutor/
zusammengestellt von J. Lippuner

Introduction

The best way to get acquainted with Microsoft FrontPage 2000 is through hands-on practice. This tutorial will show you how easy it is to build Web sites every bit as sophisticated and attractive as many of the award-winning sites on the World Wide Web today.

In the following two lessons, you'll build a "Millennium Celebration Web" that provides information about the Year 2000. We've prepared a folder of files for you to practice with while you create this web.
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What You Will Learn

This tutorial is divided into two lessons:

Lesson 1: Creating and Editing Web Pages

This lesson teaches you how to create and edit Web pages; work with text and hyperlinks; add pictures, animations, clip art, and files; format lists; position objects; design a feedback form; make a photo gallery; design a web structure; and create a web.

Lesson 2: Designing and Publishing a Web

In this lesson, you will learn how to create navigation hyperlinks; add shared borders and navigation bars to pages; insert page banners; apply and customize a graphical theme; check spelling and replace text across the web; sort and organize files and folders; view web reports; and preview and publish the finished web.

Before You Begin

This tutorial assumes that your computer meets the minimum system requirements for FrontPage 2000. For more information, please visit the FrontPage home page, at http://www.microsoft.com/frontpage [image: image3.png]


.

The screen examples in the FrontPage Tutorial assume that you have a standard monitor set to a screen resolution of 800x600, at the minimum. If you are using a different resolution or monitor, the pages you create during the lessons may look slightly different on your screen.

If you have Web server software installed

The Web site you will create while taking the FrontPage Tutorial will be saved to a folder on your local hard drive. If you upgraded from FrontPage 98 and have the Microsoft Personal Web Server installed, or if you are running Microsoft Internet Information Services (IIS), you can either accept the default destination for the tutorial web, or choose to save it directly on your Web server.

FrontPage and Microsoft Internet Explorer

To get the most out of FrontPage, installing Microsoft Internet Explorer is recommended. When Internet Explorer is installed, FrontPage provides enhanced page and themes preview. Other Web browsers currently do not support these additional features.
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You can use more than one Web browser   If you already have another type of Web browser installed on your computer, you can still safely install Microsoft Internet Explorer. When designing Web pages, you will find it is actually very beneficial to test your work in more than one type of Web browser before you publish your Web site.
If you are using Windows NT

The lessons in this tutorial assume that you are working in Windows 98. If you are using FrontPage 2000 on Windows NT, you may notice minor differences in the user interface and the locations where files are stored. For example, the "My Documents" folder in Windows 98 is called "Personal" in Windows NT. These differences do not affect the functionality of FrontPage nor do they prevent you from successfully completing the lessons in this tutorial.

Learning More About FrontPage

Throughout the FrontPage Tutorial, you may notice the Help button, as shown here. This button identifies key features and their associated keywords for the online Help system and the Answer Wizard in FrontPage.
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In the Answer Wizard, type:
How do I check spelling?
FrontPage includes a comprehensive Help system that contains conceptual overviews of key features, step-by-step procedures, and complete, context-sensitive Help. It also contains the Answer Wizard, which you can use to ask questions about features in your own words, such as "How do I check the spelling on my page?"

While taking the FrontPage Tutorial, you may come across terms that are new to you. These terms might appear in the FrontPage user interface, or they may be used in the computer industry and the Internet community. To look up the definitions of words you are unfamiliar with, turn to the Glossary in the FrontPage 2000 Getting Started book.

Lesson 1: Creating and Editing Web Pages

The World Wide Web is a great way for people to communicate with each other. While you have conversations with other people over Internet e-mail and in Internet newsgroups, you can also publish your own personal Web site — a collection of one or more pages on which you can share all sorts of information.

This tutorial will introduce you to Web page creation and Web site management, two aspects that will show you how easy and fun it is to build and maintain a Web site with Microsoft FrontPage 2000.

In this first lesson, you'll create a "Millennium Celebration Web" that provides information about the Year 2000. Its pages will contain travel destinations for millennium celebrations, an online photo album, and a list of links to other sites.

We've prepared a folder of various files for you to practice with while you create this web. When you have completed the lessons, you will have a good understanding of FrontPage and its features.

In this lesson, you will learn how to:

	· Start Microsoft FrontPage.

· Create and edit Web pages.

· Work with text and hyperlinks.

· Insert pictures and files.

· Format lists.
	· Position objects.

· Add a feedback form.

· Design a photo gallery.

· Create a web structure.

· Save your work. 


Starting FrontPage

If you haven't already installed FrontPage, you'll need to do so before you begin the tutorial. 

(To start Microsoft FrontPage
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Start button
· On the Windows taskbar, click the Start button, point to Programs, and then click Microsoft FrontPage. 

FrontPage opens and displays a blank page ready for editing.

Workspace Overview

FrontPage 2000 has a new, integrated interface that lets you create and edit Web pages and manage entire Web sites — all within one application. All toolbars and menus are consistent with Microsoft Office applications and can be fully customized. You can also use convenient keyboard shortcuts to accelerate common tasks such as opening webs and pages, printing, and many other commands.
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The Standard and Formatting toolbars are displayed by default. They provide easy access to the commands you will use most often when working in FrontPage.
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Showing additional toolbars   You can customize your workspace by displaying additional toolbars or changing the buttons they contain. On the View menu, point to Toolbars, and then select the toolbars you want to display. To add or remove buttons from toolbars, click Customize.
What you see in the main application window depends on the currently selected view.

The icons on the Views bar provide different ways of looking at the information on your page or in your web. As you work with FrontPage, you'll frequently switch between views to match the current task at hand — from the early steps of creating a page, to the moment a whole Web site is ready to be published on the World Wide Web.

When you start FrontPage, Page view is displayed by default. Page view is a powerful editing tool for creating and designing Web pages. As you enter text, place pictures, insert documents, create tables, make lists, and design the appearance of your Web pages, Page view displays them as they will appear in a Web browser. All HTML code is automatically created in the background and you don't need to manually edit any code unless you want to.

You'll begin working in Page view and learn about the other views later in this lesson.

Getting Started

For this tutorial, you'll create a Web site with five pages, on which you will tell visitors about the new millennium. Until it is published for the first time, a Web site is a work in progress. If the task of putting together a whole site seems daunting to you, don't worry. You can gradually add information and other pages to your web until it is finished. Unlike printed letters, memos, and word-processing documents, Web sites can be dynamically changed or updated even after they've been published. You can add, delete, and modify text, pictures, and entire pages at any time.

With FrontPage, you can get started easily by simply typing text on the blank document that Page view provides. For this lesson, we'll begin with the home page — the default document that greets your visitors when they surf to your Web site.

(To create a home page
The home page is the front door to your Web site. Greeting your visitors as you might do in person and providing some information about the content or subject matter of your site will spark interest in the people looking at your site. The home page also contains links to the other pages in a web.

1. On the blank page in Page view, type Welcome to my Web site! and then press ENTER.

Just like in a word processor, pressing ENTER puts the cursor on a new line.

2. Next, type the sentence Take a look around to learn more about the Year 2000, see where people all over the world will be celebrating the new millennium, and look at pictures from past New Year's fireworks. 

3. Press ENTER. 

After typing such a long sentence, you may wonder how much typing you'll need to do before getting to the fun stuff. Don't worry, for most of the Millennium Celebration Web content, we've already done the typing for you. And when you're ready to make your own Web site, FrontPage lets you import any of your existing documents directly onto your Web pages without having to retype anything.

Your page should now look like this:
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Next, you will add a picture to the bottom of the current page. Pictures can be scanned photographs, drawings, or computer graphics created in a drawing or image-editing program.

For this example, the picture you'll insert is a graphical button of the FrontPage 2000 web logo.

(To insert a picture on the home page
4. On the Insert menu, point to Picture, and then click From File. 

FrontPage displays the Picture dialog box. Because you are editing a page that isn't part of a web yet, FrontPage also opens the Select File dialog box, which lets you choose a picture to insert from your local file system.

The picture file you'll insert is located in the Tutorial folder that was installed with the FrontPage program files. 

5. In the Select File dialog box, navigate to the folder named Program Files\Microsoft Office\Office\ Tutorial by double-clicking each folder in this path until the Look in box displays the Tutorial folder. 

If you downloaded the tutorial files from the www.microsoft.com, navigate to the folder named Fptutor\Samples, or to the folder where you placed the files.

In the Tutorial folder, several files will be displayed. By default, FrontPage searches for picture files. 

6. Click the file named fp2000, and then click OK. 

FrontPage inserts the selected picture file on the current page. It is a picture of a button that your site visitors will be able to click to learn more about FrontPage 2000. 

7. Press ENTER to create a new line. 

Your page should now look like this:
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Merely inserting a picture of a button doesn't mean that anything will happen when someone clicks it in a Web browser. To make a picture or a word "clickable," it must have a hyperlink associated with it.

A hyperlink is a pointer from text or from a picture to another page or file on the World Wide Web. On the World Wide Web, hyperlinks are the primary way to navigate between pages and Web sites.

In the next steps, you'll create a hyperlink from the button you just placed on the home page.

(To create a hyperlink from a picture
8. On the home page, click the picture of the FrontPage 2000 button you previously inserted. 

When a picture is selected, it is shown with file handles — eight small squares around the outline of the picture. These can be used to resize a picture or change its appearance. When a picture is selected, FrontPage also displays the Pictures toolbar below Page view. The Pictures toolbar provides picture editing and formatting tools, which you'll learn about later. 

9. On the Insert menu, click Hyperlink. 

FrontPage displays the Create Hyperlink dialog box. Here, you specify the target of the hyperlink you are creating. This can be a page or a file in your web, on your local file system, on a Web server, or on another site on the World Wide Web.

Because you're creating a hyperlink from a button that is labeled "Microsoft FrontPage," you'll link to the Microsoft FrontPage home page on the World Wide Web. When site visitors click the button in a Web browser, they will be taken to the right place. 

10. In the URL box, type www.microsoft.com/frontpage immediately after the http:// prefix that FrontPage has provided for you. 

URL is an acronym for Uniform Resource Locator. It is the technical term for what's commonly known as an "Internet address" or "Web site address." A URL specifies the unique location of a file or a collection of files on the World Wide Web. 

11. Click OK to finish creating the hyperlink. 

You may notice that the appearance of the button itself hasn't changed. Unlike text hyperlinks, which change the color of the clickable text and underline it, picture hyperlinks do not automatically indicate the presence of the hyperlink in an obvious way. This is intentional, because changing the appearance of the picture could obscure the intended page design in some cases.

You can quickly check the existence of a hyperlink from a picture by moving the mouse pointer over the picture. If a hyperlink is present, FrontPage displays the URL the hyperlink points to on the status bar.

Next, you'll insert an animation of the number 2000 at the top of the page. Animated pictures are inserted in the same way as normal pictures.

(To insert an animated picture on the home page
1. Press CTRL+HOME to quickly jump to the beginning of the current page. 

The key combination CTRL+HOME places the cursor in the home position — the top left margin on the current page. 

2. On the Insert menu, point to Picture, and then click From File. 

This time, FrontPage immediately displays the contents of the Tutorial folder. For the duration of each work session, FrontPage remembers the names and locations of the folders you've already navigated to. 

3. In the Select File dialog box, double-click the file named 2000. 

Double-clicking file names is faster than selecting each file and clicking OK.

FrontPage inserts the animated picture of the number 2000 on the current page. This picture will look great against a dark background, which you'll apply later. While you edit pages in Page view, FrontPage purposely does not show text or picture animations, so they don't distract you from your work. You will be able to see what the animation looks like when you preview the home page later in this lesson. 

4. Press ENTER to move the welcome text to the line below. 

Your page should now look like this:
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To finish the home page, you'll center the text and pictures on it.

(To center elements on a page
1. On the Edit menu, click Select All. 

FrontPage selects everything on the current page. 

2. On the Format menu, click Paragraph. 

FrontPage displays the Paragraph dialog box. Here, you can change the alignment of selected elements, and apply indentation and custom spacing for text and graphics. 

3. In the Alignment list, click Center, and then click OK. 

FrontPage centers the text and the pictures on the home page. 

4. Click anywhere on the page to deselect all page elements. 

Now that you've invested some time and completed a number of steps, it's a good idea to save your page.

(To save the current page
1. On the File menu, click Save As. 

FrontPage displays the Save As dialog box. Here, you can specify the location for the current page, and review or change the page title, the file name, and the file type. 

2. In the Save As dialog box, click the My Documents icon on the vertical Places bar. 

The contents of your My Documents folder is displayed. If no files are displayed in the file list, then you currently do not have any other Web pages stored here. 

3. Next to the Page title field, click the Change button. 

FrontPage displays the Set Page Title dialog box. Here, the default page title is based on the first line of text on the current page. A title identifies the contents of a page when it is displayed in a Web browser. For this tutorial, you'll change the page title to something more descriptive. 

4. In the Set Page title box, type Millennium Celebration – Home Page and then click OK. 

In the Save As dialog box, the default file name is based on the first line of text on the current page. For this tutorial, change the file name to something more descriptive. 

5. In the File name box, change the suggested text to homepage, and then click Save. 

FrontPage saves the current page.

Page View Options
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Page icon
While creating the home page, you've worked exclusively in normal Page view, but there are three different ways you can choose to look at the current page.

(To display HTML tags on the current page
· In Page view, click Reveal Tags on the View menu. 

FrontPage displays graphical representations of standard HTML tags for the current page. This display is useful for people who want to know where HTML tags are placed while they design their pages.

· To hide the tags, click Reveal Tags on the View menu a second time.
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Getting more information about tags   When the Reveal Tags command is selected, you can view more information about many HTML tags by moving your mouse over each tag until a ScreenTip appears.
(To display the HTML of the current page
· In Page view, click the HTML tab at the bottom of the page. 

This is the HTML code that FrontPage has created so far while you were designing the home page. Web browsers decode these instructions to display the page. The HTML tab in Page view is intended for experienced web developers and page designers who want to customize the HTML that FrontPage creates.

If you want to set your preferences for the way FrontPage will generate HTML code, click Page Options on the Tools menu, and then click the HTML Source tab. If you're not experienced in HTML, you don't need to make any changes here. Click Cancel to close the Page Options dialog box.

· Click the Normal tab at the bottom of the page to return to normal Page view.
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Using menu commands and toolbars on the HTML tab   While working in the HTML tab, you can use many menu commands and toolbar buttons just like in normal Page view.
(To preview the current page
· In Page view, click the Preview tab at the bottom of the page. 
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If you do not have Microsoft Internet Explorer installed on your computer, the Preview tab will not be displayed, and you will not be able to preview your pages this way. For more information, see Before You Begin. 

Looking at your page on the Preview tab is a quick and convenient way to see how certain elements — including animations, movie clips, tables, and lists — will appear in a Web browser.

When you preview the home page you've created, you can see what the animation at the top of the page looks like. Each of the four digits rotates into place one by one, until the number 2000 is displayed. The color and edges of the four digits will look great against a dark background, which you will add in the next lesson. The animation effect will be repeated for as long as the current page is previewed or displayed in a Web browser.

· Click the Normal tab at the bottom of the page to return to normal Page view once again. 
Creating a Web with FrontPage

A web is the collection of a home page and its associated pages, graphics, documents, multimedia, and other files. Webs are stored on a Web server or on a computer's hard drive. FrontPage-based webs also contain files that support FrontPage-specific functionality and allow webs to be opened, copied, edited, published, and administered with FrontPage.

In the previous procedures, you learned how easy it is to create a Web page with FrontPage. As soon as you start the application, you can start typing and editing, then save the document to your hard drive — much like a word processor. While you can certainly choose to put together an entire Web site like this, it can take a lot of manual work and attention to detail to maintain hyperlinks and source files, and keep your content up to date.

When you save your pages to a web, FrontPage can automatically manage and repair hyperlinks, organize files and folders, maintain dynamic navigation bars, check spelling across all pages in the web, and generate reports that point out problems with your pages and files.

(To create a new web
1. On the File menu, click Close to close the current page. 

2. On the File menu, point to New, and then click Web. 

FrontPage displays the New dialog box. Here, you can choose from several web templates and wizards, specify where you want to save your web, and what you want to call it.

3. Make sure the One Page Web template is selected, and then press TAB. 

Pressing the TAB key moves the selection to the field where you specify the name and location of the new web.

4. In the Specify the location of the new Web box, change the suggested name to C:\My Documents\My Webs\Millennium and then click OK. 

FrontPage creates a new web named "Millennium" and displays its name in the title bar at the top of the FrontPage application window. Because you'll be working with several files in your web, FrontPage also displays the Folder List, where you can see the files and folders in your current web, similar to files and folders in Windows Explorer. You'll learn how to use the Folder List later, in Lesson 2.
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Navigation icon
5. Click the Navigation icon on the Views bar. 

When you have a web open, the icons on the Views bar let you look at the information in your web in different ways.

Navigation view shows a graphical representation of the structure of your Web site. Because you created a one-page web, FrontPage has automatically designated it as the web's home page — indicated with a small icon of a house. While in Navigation view, FrontPage also displays the Navigation toolbar, which you can drag anywhere on your screen.

Next to the Views bar, FrontPage displays the optional Folder List, just like it did in Page view.

In a moment, you'll replace the new, empty home page with the one you created earlier in this lesson. First, however, you'll create the structure for the other four pages that the Millennium Celebration Web will have.

Creating a web structure in Navigation view enables features such as page banners and navigation bars that are automatically updated whenever you change, add, or remove pages in your web. This makes it easy to change things around. You'll learn more about these features later.

(To create a navigation structure
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New Page button
1. In Navigation view, click the New Page button on the toolbar. 

FrontPage creates a new page labeled "New Page 1" below the home page. Pages in Navigation view aren't the actual pages in the current web; they are placeholders that point to them. This way, you can easily experiment with the structure and organization of a web before you create its content. 

2. To quickly create the remaining three pages, hold down CTRL on your keyboard and press N three times. 

CTRL+N is a keyboard shortcut for the New Page command. FrontPage supports common Windows and Microsoft Office accelerator keys that help speed up repetitive tasks. The pages you just created appear below the home page, because the home page was selected when you issued the command.

In Navigation view, the selected page is blue, while others are yellow. 

3. With the home page still selected, press TAB. 

Pressing the TAB key moves the selection to the next page in the structure and activates the page title for editing. 

4. When New Page 1 is selected, type Background and then press TAB. 

"Background" is the page title of one of the pages you'll create for the Millennium Celebration Web. Next, you'll specify the page titles for the other pages. 

5. When New Page 2 is selected, type Destinations and then press TAB. 

6. When New Page 3 is selected, type Photo Album and then press TAB. 

7. Finally, when New Page 4 is selected, type Links and then press ENTER. 

Pressing ENTER after editing a page title saves the new title without selecting another page. To deselect all pages, click anywhere outside the pages in Navigation view.

Your screen should now look like this:
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An alternate way to add pages   You can add new pages in Navigation view by right-clicking a page and choosing the New Page command from the shortcut menu. This command will create a new page below the selected page.
You can quickly open pages in Page view for editing by double-clicking the pages in Navigation view or in the Folder List.

Next, you'll replace the blank home page FrontPage created from the web template by importing the home page you created and saved to your My Documents folder earlier in this lesson.

(To import a page into a web
1. In Navigation view, double-click the Home Page to open it in Page view. 

FrontPage opens the blank home page that was created from the web template.
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Folder List button
2. On the toolbar, click the Folder List button to hide the Folder List in Page view. 

3. On the Insert menu, click File. 

FrontPage displays the Select File dialog box. Here, you can insert Web pages, word-processing documents, text files, and other documents on the current page. 

4. In the Select File dialog box, navigate to the My Documents folder. 

5. When My Documents is displayed in the Look in list of the Select File dialog box, click the file named homepage, and then click Open. 

FrontPage imports your previously saved home page to the current page.
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Save button
6. To save the current page to your web, click Save on the File menu, or click the Save button on the toolbar. 

FrontPage displays the Save Embedded Files dialog box. Here, you can preview, rename, save, and update embedded files that the current web will use.

When you previously saved this page to the My Documents folder on your file system, FrontPage left the two pictures you inserted in their original location — the FrontPage Tutorial folder. The home page merely pointed to the picture files without copying them to the same folder the page was saved to. To keep Web sites portable, however, you should always keep associated pages and files as part of the web that uses them. 

7. In the Save Embedded Files dialog box, click OK. 

FrontPage saves the home page as Index.htm and saves copies of the embedded picture files, 2000.gif and Fp2000.gif, to the current web.
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Home pages have reserved names   FrontPage will automatically name home pages one of two reserved names that you should not change unless you need to. If you are running local Web server software such as Microsoft Personal Web Server or Internet Information Services (IIS) on your computer, the home page will be named Default.htm. If you do not have a local Web server installed, or when you save a page to your local hard drive instead of a web on a Web server, the home page will be named Index.htm. 

These names are reserved for home pages because Web browsers will automatically look for them when a site visitor types the URL to your Web site without a specific page reference.

Creating Web Content

Now that the home page is part of the current web, you will create the content for the other pages in the Millennium Celebration Web.

(To edit the Background page
1. Click the Navigation icon on the Views bar to switch back to Navigation view. 

Note that the Folder List now shows the two picture files you saved to the current web. The file Index.htm is the new home page. You can later discard the remaining copy of the home page from your My Documents folder.

In the Folder List, the file names of the other pages were automatically derived from the page titles you typed into the pages in Navigation view. For this tutorial, we won't change the names. 

2. Double-click the Background page to open it in Page view. 

This page will provide some background about the new millennium and the Year 2000 for site visitors. For this tutorial, we have provided this text for you, so you can simply insert it on the page without having to type it. 

3. When the blank page is displayed in Page view, click File on the Insert menu. 

4. In the Select File dialog box, navigate to the folder named Program Files\Microsoft Office\Office\Tutorial by double-clicking each folder in this path until the Look in box displays the Tutorial folder. 

If you downloaded the tutorial files from the www.microsoft.com, navigate to the folder named Fptutor\Samples, or to the folder where you placed the files.

5. Next, click the Files of type list and click Text Files (*.txt) to display the text files in the Tutorial folder. 

FrontPage displays the single file matching the criteria. 

6. Click year2000 in the list, and then click Open. 

The text you are inserting isn't saved in HTML format, so FrontPage displays the Convert Text dialog box to let you control how the text will be imported. 

7. In the Convert Text dialog box, click Normal paragraphs with line breaks, and then click OK. 

FrontPage imports the text file and places it at the insertion point on the Background page.

8. On the toolbar, click the Save button to save changes to the Background page. 

Next, you will prepare the page titled Destinations. It will tell site visitors about popular travel destinations that many people will visit to celebrate the new millennium. On this page, you will also provide a feedback form that collects travel ideas from people browsing the Millennium Celebration Web.

(To edit the Destinations page
1. On the toolbar, click the Folder List button to show the Folder List in Page view. 

2. Double-click destinations.htm in the Folder List to open the page in Page view. 

3. Click the Folder List button to hide the Folder List. 

4. When the blank page is displayed in Page view, click File on the Insert menu. 

5. In the Select File dialog box, click the Files of type list, and then click Rich Text Format (*.rtf) to display the formatted text file in the Tutorial folder. 

FrontPage displays the file matching the criteria. 

6. Double-click the file events. 

Because this type of file contains formatting, FrontPage automatically converts the formatted text to HTML format. 

7. On the toolbar, click the Save button to save changes to the Destinations page. 
Automatic Spelling Checks

Take a moment to scroll to the top of the Destinations page. In the first paragraph, note the red, wavy underline under the name "Balleny," the name of an island in Antarctica.

In Page view, FrontPage automatically checks the spelling of text you type on the current page, just like Microsoft Word, PowerPoint, and other Microsoft Office applications do. An underlined word doesn't necessarily mean the word is spelled incorrectly. FrontPage may simply prompt you to verify unknown or suspected words, which happens most commonly with names of people and places.

If you know that the spelling of a suspected word is correct, you can either choose to ignore such words and keep them unchanged, or add them to a custom dictionary that FrontPage will keep for subsequent spelling checks. If the word is indeed misspelled, you can quickly insert the corrected spelling by right-clicking the suspected word and selecting a suggested correction.

There are three ways FrontPage can check spelling for you:

· Automatic spelling check as you type text 

· Manual spelling check of the current page 

· Cross-web spelling checks of all pages in a web

Page-based spelling checks are available in Page view by right-clicking suspect words or by clicking the Spelling command on the Tools menu. Cross-web spelling checks are available in every web view.

Spelling checks are important if you want your web content to give visitors a professional impression. If words are misspelled on a single page, people might question the accuracy of your entire Web site content. The flexible spelling features in FrontPage give you the option of checking spelling page by page as you create and edit content, or doing it all at once, just before you publish your web to the World Wide Web.

For this tutorial, you'll check the spelling of your entire web later, in Lesson 2.

Designing a Page

The Background page will inherit its formatting from a graphical theme that you will apply to the Millennium Celebration Web later, in Lesson 2. The Destinations page, however, requires some more design work.

To help the reader differentiate the paragraph headings, list of travel destinations, and event details that the text on this page talks about, you will add some pictures, format paragraph styles, and create a bulleted list.

(To create a bulleted list
1. With the Destinations page still displayed in Page view, find the words "Times Square in New York." 

2. Use the scroll bar to bring the entire list of destinations into view, beginning with "Times Square in New York" and ending with "The Acropolis in Greece." 

3. Click just to the left of the letter T in "Times Square," hold down SHIFT, click just after the word "Greece," and then release SHIFT. 
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Bullets button
4. On the toolbar, click the Bullets button. 

FrontPage converts the selected text to a bulleted list. 

5. Click anywhere on the page to deselect the list. 

Your page should now look like this:
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You can also create numbered lists with FrontPage. When you add new items to a numbered list, FrontPage automatically numbers them sequentially. You can add to bulleted and numbered lists by pressing ENTER after an item in the list. To end a list, press ENTER twice after typing the last list item.

Next, you will place four pictures on the current page and use positioning features in FrontPage to align the pictures with the paragraphs they are associated with. This will create a more interesting page layout.

(To position pictures with text
1. With the Destinations page still displayed in Page view, scroll down to the words "France and England" in the paragraph just following the list. 
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Insert Picture From File button
2. Click just to the left of the letter F in "France," press HOME, and then click the Insert Picture From File button on the toolbar. 

When you last inserted a picture, you did not have a web open, and FrontPage automatically displayed the Select File dialog box. Now that a web is open, FrontPage assumes you want to work with pictures that are already part of your web, and therefore displays the Picture dialog box.
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Select File button
3. Because you haven't yet added the picture you want to the current web, click the Select File button in the Picture dialog box. 

FrontPage displays the Select File dialog box. 

4. Click the file named paris, and then click OK. 

FrontPage inserts a picture of the Eiffel Tower in Paris just before the current paragraph. 

5. Next, click the picture of the Eiffel Tower to select it. 

6. On the Format menu, click Position. 

FrontPage displays the Position dialog box. 

7. Under Wrapping style, click Right, and then click OK. 

The picture is aligned with the right margin of the current page and the text now flows around it. 

8. On the toolbar, click the Save button to save changes to the Destinations page. 

9. In the Save Embedded Files dialog box, click OK. 

Your page should now look like this:
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You can either place pictures one by one in this way, or you can import all the pictures you will use on your pages all at once. While importing single files is done in Page view, inserting a group of files or entire folders is done in Folders view.

(To add a group of files to the current web
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Folders icon
1. Click the Folders icon on the Views bar to switch to Folders view. 

Folders view is an expanded view of the Folders List that you have seen in Navigation and Page view. Similar to the way you look at files in Windows Explorer, here you can view details about the files and folders in your web, and perform such file management tasks as adding, deleting, moving, copying, and renaming files.

2. On the File menu, click Import. 

FrontPage displays the Import dialog box. Here, you can add files and folders from your local file system, a local area network, a company file server, or a resource on the Internet or World Wide Web, such as an FTP server. 

3. In the Import dialog box, click Add File. 

4. In the Add File to Import List dialog box, navigate to the folder named Program Files\Microsoft Office\Office\Tutorial by double-clicking each folder in this path until the Look in box displays the Tutorial folder. 

If you downloaded the tutorial files from the www.microsoft.com, navigate to the folder named Fptutor\Samples, or to the folder where you placed the files.

5. Next, click the Files of type list, and then click GIF and JPEG (*.gif, *.jpg) to display all picture files in the Tutorial folder. 

6. Click the file named firewks1 in the list to select it. 

7. Next, hold down CTRL, and while doing so, click to select the files named firewks2, firewks3, firewks4, japan, london, and sanfran. 

FrontPage supports standard Windows file selection methods. 

8. When the files are selected in the Add File to Import List dialog box, release CTRL, and then click Open. 

FrontPage adds the pictures you selected to the list in the Import dialog box. 

9. Click OK to import the listed files to the current web. 

Now that the remaining pictures are added to your web, it's time to finish the layout of the Destinations page.

(To finish the page layout 

1. Click the Page icon on the Views bar to return to Page view. 

2. Locate the sentence beginning with "England is planning to reconstruct…," click just to the left of the letter E in "England," and then click the Insert Picture From File button on the toolbar. 

3. In the Picture dialog box, note that your previously imported pictures are now available, and then select the file london.gif from the list. 

When you click a single picture file in the Picture dialog box, FrontPage displays a preview of the picture, so you can make sure it's the one you want to insert. This is one of the benefits of adding all your pictures to the web before inserting them on your pages.

The Picture dialog box also links to the clip art gallery that is included with FrontPage. And if you have a scanner or a digital camera, you can click the Scan button in this dialog box to acquire original pictures from those sources. 

4. Click OK to insert the picture 
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Align Left button
5. Click the picture of the Tower of London you just inserted, and then click the Align Left button on the toolbar to position the picture in the left margin and make the text wrap around it. 

6. Next, scroll down to the sentence beginning with "World-famous Times Square…," click just to the left of the letter W in "World-famous," and then click the Insert Picture From File button on the toolbar. 

7. Select the file sanfran.gif from the list, and then click OK. 

[image: image30.png]



Align Right button
8. Click the picture of the Golden Gate Bridge, and then click the Align Right button on the toolbar to position the picture in the right margin and make the text wrap around it. 

9. Finally, scroll down to the sentence beginning with "A travel agency in Japan…," click just to the left of the letter A at the beginning of the sentence, and then click the Insert Picture From File button on the toolbar. 

10. Double-click the file japan.gif on the list. 

11. Click the picture of the Japanese temple, and then click the Align Left button on the toolbar to position the image in the left margin and make the text wrap around it. 

Your page should now look like this:
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Positioning pictures and other page elements around text on your page makes for a more interesting design, much like pages in a magazine or newspaper. By positioning pictures in the margin, your page layout will be preserved even when the page is viewed at a different screen size and resolution in a Web browser.

To finish the Destinations page, you will create a feedback form so that you can interact with site visitors who want to participate. A feedback form can be used to collect comments and information from people visiting your Web site.

(To create a feedback form 

1. In Page view, press CTRL+END to quickly jump to the bottom of the current page, or scroll all the way down using the scroll bar. 

2. On the new, blank line, type Tell Us Where You'll Be! and then press ENTER. 

3. On the next line, type Do you have great travel plans for a millennium party? Then tell us about them below! 

4. Press ENTER to create a new line. 

5. On the Insert menu, point to Form, and then click Form. 

FrontPage inserts a new form on the current page. The dashed lines indicate the form's boundary. By default, a new form contains Submit and Reset push buttons.

Next, you will customize the default form by adding form-fields and form-field labels, to let site visitors know what kind of information you want them to enter into the form.

(To customize the form
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Center button
1. With the cursor still positioned to the left of the Submit button, click the Center button on the toolbar, and then press ENTER to add some space to the form. 

2. Press the UP ARROW key on your keyboard to return the cursor to the beginning of the form. 

FrontPage moves the cursor to the middle of the first line of the form. 

3. On the first line, type Your Name: and then press SHIFT+ENTER. 

Holding SHIFT while pressing ENTER creates a line break. Line breaks are useful for spacing lines of text more closely together than standard paragraph spacing. 

4. On the Insert menu, point to Form, click One-Line Text Box, and then press ENTER. 

FrontPage inserts a one-line text input field into the form. 

5. On the next line, type Your E-mail Address: and then press SHIFT+ENTER. 

6. On the Insert menu, point to Form, click One-Line Text Box once more, and then press ENTER. 

7. On the next line, type Your travel plans are: and then press SHIFT+ENTER. 

8. On the Insert menu, point to Form, and then click Scrolling Text Box. 

FrontPage inserts a scrolling text input field into the form. 

9. Double-click the scrolling text box you just inserted. 

FrontPage displays the Scrolling Text Box Properties dialog box. Here, you can change the appearance of the text box. 

10. In the Scrolling Text Box Properties dialog box, change the Width in characters to 30 and the Number of lines to 5, and then click OK. 

The scrolling text box has increased in size, which will encourage site visitors to write a little more than just a brief line of text about their New Year's plans. 

Now that your form and the Destinations page are finished, it's a good idea to save your work. 

11. On the toolbar, click the Save button to save changes to the Destinations page. 

Your page should now look like this:
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Good work! The feedback form is finished and so is the Destinations page. In the next part of the lesson, we'll add the last two pages — an online photo album and a list of links to your favorite sites on the World Wide Web.

Creating a Photo Album
The World Wide Web has a graphical interface, so it's no surprise that the most popular Web sites have pictures to look at. Scanners and digital cameras have become much more affordable, and many photo-developing places now offer to put your pictures on a CD-ROM so you can share them online.

While working with the graphics and clip art in the previous procedures, you saw how easy it is to place pictures on Web pages using FrontPage. In this part of the lesson, you'll create an online photo album of actual photographs. For the Millennium Celebration Web, you'll share some great photos of fireworks.

(To edit the Photo Album page
1. On the toolbar, click the Folder List button to show the Folder List in Page view. 

2. Double-click photo_album.htm in the Folder List to open the page. 

3. Click the Folder List button to hide the Folder List. 

4. When the blank page is displayed in Page view, type New Year's Fireworks on the first line, then press ENTER. 

5. On the next line, type Here are some great pictures from past New Year's celebrations. Click each thumbnail to see the full-size picture, then use your Web browser's Back button to return to this page. 

6. Press ENTER twice to create some space. 

Next, you'll place four pictures on the current page. They are already part of the web because you imported them in the previous procedure. 

7. On the toolbar, click the Center button. 

8. Click the Insert Picture From File button. 

9. In the Picture dialog box, select firewks1.jpg, and then click OK. 

FrontPage inserts the first of the four fireworks pictures you will place on this page. Next, insert the other three pictures, one after the other. Don't worry about their large size and proper placement just yet. 

10. Repeat steps 8 and 9 with the picture files named firewks2.jpg, firewks3.jpg, and firewks4.jpg. 

The remaining pictures are placed on the page, one after the other. 

11. On the toolbar, click the Save button to save changes to the Photo Album page. 

Having lots of large pictures on your Web page for people to look at is great, but not everyone has a fast connection to the Internet. Over a dial-up connection with a modem, pages with large pictures and complex designs can take a long time to download before the Web browser displays the page.

Imagine changing the channel on your TV and having to wait several minutes before you see what's playing on that channel. It's no different on the World Wide Web. There are many other "channels" or Web sites to look at. No matter how interesting your site may be, people may quickly lose interest if it takes too long to download.
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On the status bar, FrontPage automatically displays the estimated time it will take for the current page to download over the Internet when the page is opened in a Web browser. The default measurement assumes that your site visitors will have a 28.8K modem connection. You can adjust this measurement for other common connection speeds by right-clicking the red hourglass icon and choosing another connection speed from the shortcut menu.

For this tutorial, we'll leave the download speed at 28.8K. On the current page, you can see that the estimated download time for the Photo Album page is 97 seconds. This means that people who will visit the Millennium Celebration Web will have to wait a minute and a half before they can see the four pictures you've just inserted. That's quite a long time to wait for just four pictures.

By creating thumbnails — small preview images of pictures — you can give your visitors the choice of whether they want to spend time downloading the full-size pictures on your page. FrontPage makes creating thumbnails easy with the Auto Thumbnail tool.
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Setting thumbnail preferences   You can change default options for the thumbnails FrontPage creates of your pictures. On the Tools menu, click Page Options, and then click the AutoThumbnail tab. Here, you can specify the size of automatic thumbnails FrontPage creates, whether each thumbnail should have a border to indicate the presence of its associated hyperlink, and whether thumbnails should be displayed with a beveled edge to simulate a button. 

Before proceeding with the next procedure, change the default setting from Width to Height in the the AutoThumbnail tab of the Page Options dialog box.

(To create thumbnails of pictures 

1. With the Photo Album page still displayed in Page view, press CTRL+HOME to quickly jump to the beginning of the current page, or scroll all the way up using the scroll bar. 

2. Click the first fireworks picture to select it. 

FrontPage displays the Pictures toolbar below Page view.
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Auto Thumbnail button
3. On the Pictures toolbar, click the Auto Thumbnail button. 

FrontPage creates a thumbnail of the selected picture and adds a blue border to indicate that it contains a hyperlink to the original picture in your web. When site visitors visit this page, they can click each thumbnail to download the full-size pictures. 

4. Repeat steps 2 and 3 for the other three pictures on the Photo Album page. 

5. Click the second fireworks thumbnail to select it. Drag one of the top corner handles to make this thumbnail the same height as the first thumbnail. Repeat this step for the third fireworks thumbnail. 

6. Click anywhere on the page to deselect the last thumbnail. 

Your page should now look like this:
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When FrontPage creates thumbnails, it doesn't actually modify the original picture files in any way. Instead, it quickly makes a copy of each picture, resizes it, downsamples the display resolution of the picture, inserts a hyperlink pointing to the original picture file, and adds a border around the thumbnail to indicate the presence of a hyperlink.

You can see why the Auto Thumbnail button is a real timesaver. Doing all of that manually for each picture could take a while. 

7. On the toolbar, click the Save button to save changes to the Photo Album page. 

Because FrontPage made small copies of the pictures that are represented by a thumbnail, it needs to save the thumbnails to the current web. The names of the thumbnail picture files are the same as the original pictures, but FrontPage adds a "_small" suffix to each file name for easy identification. 

8. In the Save Embedded Files dialog box, click OK. 

FrontPage saves the four thumbnails to the Millennium Celebration Web.

Because you have an even number of pictures, you can arrange them a little better than all on one line. You can treat thumbnails like other pictures on your pages and move them where you want them.

(To finish the Photo Album page 

1. Click the first thumbnail and then press HOME to move the cursor to the left of it. 

2. Press the RIGHT ARROW key on your keyboard to move the cursor between the first and second thumbnail. 

3. Press the TAB key. 

FrontPage creates space between the first and second thumbnail. 

4. Next, press the RIGHT ARROW key again to move the cursor between the second and third thumbnail. 

5. Press ENTER. 

FrontPage moves the third and fourth thumbnail to the next line. 

6. Press the RIGHT ARROW key once more to move the cursor between the third and fourth thumbnail. 

7. Press the TAB key. 

FrontPage creates space between the third and fourth thumbnail. 

8. On the toolbar, click the Save button to save changes to the Photo Album page. 

Your page should now look like this:
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Now take another look at the FrontPage status bar. The Photo Album page previously would have taken 97 seconds to download.
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After replacing the large pictures with thumbnails, the Photo Album page now only takes 4 seconds to download. That's much better!

Linking to Other Web Sites

Now only the Links page remains to be edited. For this tutorial, this page will contain a list of text hyperlinks to some other sites on the World Wide Web.

When you create your own webs, you can create hyperlinks pointing to other Web sites that relate to the subject matter of your own pages. This lets visitors browse to similar sites without having to search for them.

(To begin the Links page
1. On the toolbar, click the Folder List button to show the Folder List in Page view. 

2. Double-click links.htm in the Folder List to open the page in Page view. 

3. Click the Folder List button to hide the Folder List again. 

4. When the blank page is displayed in Page view, type Links to My Favorite Sites and then press ENTER. 

Next, you will create a simple text animation of the paragraph heading. FrontPage includes a collection of fun text effects that you can easily apply to text headings or entire paragraphs.

(To create a dynamic text effect
1. On the Links page, click anywhere in the text Links to My Favorite Sites.

2. On the Format menu, click Dynamic HTML Effects. 

FrontPage displays the DHTML Effects toolbar. Here, you make sequential selections that will create a simple dynamic HTML (DHTML) script to animate the text when it is displayed in a Web browser.

Dynamic HTML is an extension of the HTML language that lets you create presentation effects for text and objects, much like in a Microsoft PowerPoint slide show. Using the DHTML Effects toolbar, you can add simple effects to your pages without the need to know programming.

3. In the On list, click Page load. 

This will instruct the Web browser to begin the effect when the page loads.

4. In the Apply list, click Hop. 

FrontPage applies the Hop effect. In a Web browser, this effect will cause each word to bounce onto the page.

5. Click the Close box in the upper right corner of the DHTML Effects toolbar. 

The DHTML Effects toolbar closes and the dynamic text effect is indicated in Page view with light blue shading.
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Previewing text effects   If you have Microsoft Internet Explorer installed, you can click the Preview tab in Page view to see the effect as it will appear in a Web browser. To change the effect, click Normal to return to Page view, select the text containing the effect, click Dynamic HTML Effects on the Format menu, and then apply the new effect you want.
Next, you will add text hyperlinks pointing to other sites on the World Wide Web. With FrontPage, you can create text hyperlinks in a number of ways, which you will learn next. When you create your own webs, you can create hyperlinks using your preferred method.

(To create hyperlinks from text
1. On the Links page, press the DOWN ARROW key, and then type MSN - The Microsoft Network and then press ENTER. 

2. Click and drag the mouse over the words you just typed to select them. 

3. On the Insert menu, click Hyperlink. 

FrontPage displays the Create Hyperlink dialog box. Here, you specify the target of the hyperlink you are creating. This can be a page or a file in your web, on your local file system, on a Web server, or on another site on the World Wide Web.

4. In the URL box, type www.msn.com immediately after the http:// prefix that FrontPage has provided for you, and then click OK. 

"HTTP" stands for Hypertext Transfer Protocol. This is the Internet protocol that allows World Wide Web browsers to retrieve information from Web servers. The text "www.msn.com" is the URL of MSN, the Microsoft Network.

5. On your keyboard, press the DOWN ARROW key to deselect the text. 

The words "MSN - The Microsoft Network" have changed from black default text to blue text, and the words are now underlined to indicate the presence of a hyperlink. When this page is displayed in a Web browser, clicking this hyperlink will retrieve and display the MSN home page.

Before creating the next hyperlink, you'll insert a special character symbol to indicate a trademark on the current page.

(To insert special characters or symbols
1. Click the mouse just after the letters MSN in the hyperlink you just created.

2. On the Insert menu, click Symbol. 

FrontPage displays the Symbol dialog box. Here, you can select and insert special characters at the insertion point. You can insert multiple symbols while this dialog box is displayed.

3. In the Symbol dialog box, select the trademark (TM) symbol, click Insert, and then click Close. 

FrontPage inserts the trademark symbol after the letters MSN. You can use the Symbol command to insert characters that you may not be able to type directly with your keyboard.

Next, you will create an automatic hyperlink. This method of creating hyperlinks is quick and easy, because it lets you bypass the Create Hyperlink dialog box.

(To create an automatic hyperlink
1. On the Links page, press the DOWN ARROW key, type http://www.yahoo.com, and then press ENTER. 

Yahoo! is a popular Internet service that lets you look for information on the World Wide Web using search keywords and subject categories.

As soon as you press ENTER, the URL you typed changes from black to blue text and is underlined to indicate the presence of a hyperlink. Like other Microsoft Office applications, FrontPage supports automatic hyperlink creation.

Since a URL by itself is not always very descriptive, however, you'll want to change it to the name of the site that the hyperlink points to. You can overtype the text without erasing the hyperlink.

2. Using the mouse, click and drag over the URL you just typed to select it. 

3. When the URL http://www.yahoo.com is selected, type Yahoo! to replace the selected text. 

The hyperlink still points to the same URL, but it is now labeled with the site's name.

Next, you'll create a hyperlink using your Web browser. This method of creating hyperlinks is the most accurate, because you actually visit the page the hyperlink will point to before creating the hyperlink. In addition, FrontPage copies the URL from the Web browser address field, so once the address is verified, you don't have to type it again.
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If you do not have access to the World Wide Web while taking the FrontPage Tutorial, skip the following procedure and practice these steps the next time you're connected to the Internet. 

(To create a verified hyperlink
1. Press the DOWN ARROW key to move the insertion point to the blank line below the previous hyperlink. 

2. Type Microsoft FrontPage 2000 and then press ENTER. 

3. Click and drag the mouse over the words you just typed to select them.

[image: image42.png]



Hyperlink button
4. On the toolbar, click the Hyperlink button. 

FrontPage displays the Create Hyperlink dialog box. 
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Web Browser button
5. In the Create Hyperlink dialog box, click the Web Browser button. 

FrontPage starts your Web browser. When you visit the page that the hyperlink should point to and then switch back to FrontPage, the URL box will contain the address of the target page. 

6. In your Web browser's Address (or Location) box, type http://www.microsoft.com/frontpage and then press ENTER. 

The Web browser displays the Microsoft FrontPage home page, where you can learn more about FrontPage, download updates, and find answers to common questions. 

7. On your keyboard, press ALT+TAB (or click the Microsoft FrontPage taskbar button on the Windows taskbar) to switch back to the Create Hyperlink dialog box. 

The URL of the Microsoft FrontPage home page is now entered into the URL box in the Create Hyperlink dialog box. 

8. Click OK. 

9. On your keyboard, press the DOWN ARROW key to deselect the text. 

The words "Microsoft FrontPage 2000" are now underlined to indicate the presence of a hyperlink. 

10. On the toolbar, click the Save button to save changes to the Links page. 

Your page should now look like this:
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Formatting Paragraph Headings

Now that you have successfully created the content on all the pages in your web, you'll apply paragraph and font formatting to make the paragraph headings on all pages look consistent.

(To apply paragraph styles to headings
1. On the Window menu, click index.htm. 

FrontPage brings the home page back into view. When you have more than one page open in Page view, you can use the Window menu to switch between them. The current page will always be listed at the top of this menu.

2. Click anywhere in the heading Welcome to my Web site! at the top of the page.

3. Click the Style list on the Formatting toolbar, and change Normal to Heading 3. 

FrontPage applies the Heading 3 style to the current line of text. The size of the text isn't affected, but the text is now bold.

Heading styles in the Style list are based on universal HTML standards. A level 1 heading is the largest possible text style for Web pages, and a level 6 heading is the smallest.

4. On the toolbar, click the Save button to save the home page. 

5. On the Window menu, click background.htm. 

FrontPage brings the Background page back into view.

6. Click anywhere in the heading The New Millennium at the top of the page. 

7. Click the Style list on the toolbar, and then click Heading 4. 

8. Repeat steps 6 and 7 with the heading What's in a Number? on the lower half of the Background page. 

9. On the toolbar, click the Save button to save changes to the Background page. 

(To repeat paragraph formatting with the Format Painter

FrontPage provides a convenient way to copy the formatting styles from one selection of text to another with the push of a button. You'll practice how to do this on the Destinations page.

1. On the Window menu, click destinations.htm. 

FrontPage brings the Destinations page back into view.

2. Click anywhere in the sentence Planning a Millennium Getaway at the top of the page. 

3. Click the Style list on the toolbar, and then click Heading 4.
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Format Painter button
4. When the style has been applied, click anywhere in the heading, and then click the Format Painter button on the toolbar. 

5. Using the scroll bar, scroll down to the heading Tell Us Where You'll Be.
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Format Painter pointer
6. Click the mouse to drag the Format Painter pointer over the words Tell Us Where You'll Be, and then release the mouse button. 

FrontPage copies the formatting from the previous heading and applies it to the current heading. The Format Painter tool is particularly useful when you want to easily duplicate several concurrent formatting choices from one selection of text to another.

7. On the toolbar, click the Save button to save the Destinations page. 
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Copying formatting to multiple locations   You can repeat text formatting over more than one selection of text by double-clicking the Format Painter button after selecting the format you want to copy. Select the various text locations you want to copy the formatting to, then click the Format Painter button again when you're finished.
Next, you'll finish formatting the page headings on the remaining two pages.

(To finish applying paragraph styles to headings
1. On the Window menu, click photo_album.htm. 

FrontPage brings the Photo Album page back into view.

2. Click anywhere in the sentence New Year's Fireworks at the top of the page. 

3. Click the Style list on the toolbar, and then click Heading 4. 

4. On the toolbar, click the Save button to save the Photo Album page. 

5. On the Window menu, click links.htm. 

6. Click anywhere in the sentence Links to My Favorite Sites. 

7. Click the Style list on the toolbar, and then click Heading 4. 

8. On the toolbar, click the Save button to save the Links page. 

Congratulations, you've successfully completed Lesson 1.

What's Ahead

In Lesson 2, you'll enhance the appearance of the Millennium Celebration Web by adding shared borders, navigation bars, and a graphical theme, and you will learn how to preview, test, organize, and publish the finished web.

Finishing Lesson 1

You can continue with Lesson 2 now, or close Microsoft FrontPage and continue the tutorial at a later time.

(To close Microsoft FrontPage
· On the File menu, click Exit. 

The FrontPage application closes. 

Lesson 2: Designing and Publishing a Web

In Lesson 1, you learned how easy it is to create Web pages with Microsoft FrontPage and then add them to a new web.

In this second lesson, you'll continue working with the Millennium Celebration Web you created by adding navigation bars to its pages, applying and customizing a graphical theme, previewing and testing the web, and then preparing the web for publication on the World Wide Web.

Before you publish a web, you'll want to make sure its pages and files are well organized, all of its hyperlinks are working, pages are free of spelling errors, and you have enough space available on the target Web server. FrontPage can help you complete these important tasks.

In this lesson, you will learn how to:

	· Create hyperlinks to other pages within a web.

· Add shared borders and navigation bars.

· Apply and customize a graphical theme.

· Preview and test a web in a Web browser.

· Organize files and folders.
	· Generate a Site Summary report.

· Check spelling across all pages in a web.

· Replace text on Web pages.

· Create and assign web tasks.

· Publish a web to the World Wide Web. 


Enhancing the Appearance of a Web

If you're continuing this lesson directly from Lesson 1, the Millennium Celebration Web should still be open in FrontPage. If this is the case, skip down to the procedure named "To create hyperlinks to other pages."

If you're continuing this tutorial from a previous session, then you must first open the web before you can work with its pages.

(To open an existing web
1. On the Windows taskbar, click the Start button, point to Programs, and then click Microsoft FrontPage.

2. On the File menu, point to Recent Webs, and then click C:\My Documents\My Webs\Millennium to open the Millennium Celebration Web you created in Lesson 1. 

FrontPage opens the web. The application title bar now reads "Microsoft FrontPage – C:\My Documents\My Webs\Millennium."

[image: image48.png](& Microsoft FrontPage -

:\My Documents'My Webs'Millennium





Because you'll be working with the pages you've already created, you can close the blank page that opened by default in Page view.

3. On the File menu, click Close, or click the Close button in the upper right corner of the page. 

FrontPage closes the current page. Page view is now blank, but the Millennium Celebration Web remains open.

While creating hyperlinks from pictures and text in Lesson 1, you may have noticed that you don't have any connections yet between the pages in your web. Even if someone surfed to your current home page, they would have no way of getting to the other pages. In the next section, you'll learn how easy it is to make navigation hyperlinks to other pages.

(To create hyperlinks to other pages
1. On the toolbar, click the Folder List button to show the Folder List in Page view. 

2. Double-click index.htm in the Folder List to open the home page in Page view. 

You'll keep the Folder List visible while you create hyperlinks to the other pages in your web.

3. When the home page is displayed in Page view, press CTRL+END to place the cursor at the end of the home page. 

4. Next, locate the page background.htm in the Folder List. 

The folders and files in the Folder List are shown in alphabetical order. The icon of each file gives you a clue about what kind of file it is.

You will now drag and drop the Background page onto the bottom of the home page. When you do this, FrontPage will create a hyperlink to the Background page on the home page.

5. Click and hold the mouse button on background.htm in the Folder List, move the mouse pointer on the line below the FrontPage button at the bottom of the home page, and then release the mouse button. 

FrontPage displays the shortcut mouse pointer while you drag the mouse to indicate that it will not actually insert the Background page, but will create a hyperlink pointing to it.

FrontPage inserts the page title of the Background.htm file ("Background") as the hyperlink text. The blue underlined text shows the presence of the hyperlink.

6. Repeat steps 4 and 5 with the other pages in the Millennium Celebration Web, including Destinations.htm, Links.htm, and Photo_album.htm. Place each link just after the previous one. 

7. On your keyboard, press the DOWN ARROW key to deselect the last hyperlink. 

Your page should now look like this:
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While you can manually create hyperlinks to the other pages in your web this way, doing so for all pages in a web can become a time-consuming and tedious task, especially for larger webs. Worse, if you decide to add or remove pages in the current web after creating hyperlinks, you'll have to manually add or remove the hyperlinks to them.

FrontPage has a better way to create, manage, and automatically update the navigation hyperlinks that connect your pages together. Before you learn how to do this, let's get rid of the four hyperlinks you just made.

(To use the multiple Undo command
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Undo button with arrow
1. On the toolbar, click the small arrow just to the right of the Undo button. 

2. FrontPage displays the Undo history, which shows the last several actions you can reverse. The first of these actions is selected by default. If you were to click it, then only that action would be reversed. You can also move the mouse over other entries in this list to include them in the Undo command.

3. Since we want to get rid of all four hyperlinks you just dragged and dropped onto the home page, move the mouse down the list to select all four occurrences of Drop. 

The status bar in the Undo history window should read Undo 4 Actions.

4. Click the mouse on the last occurrence of Drop in the list. 

FrontPage reverses the last four actions you took, and the four hyperlinks you created are removed from the home page.

5. To save the current page, click Save on the File menu, or click the Save button on the toolbar. 
Adding Shared Borders and Navigation Bars
For the Millennium Celebration Web, you will let FrontPage manage the hyperlinks that site visitors will click to move around the pages in your web. FrontPage achieves this with a combination of two powerful features: shared borders and automatic navigation bars.

Shared borders are page regions reserved for content that you want to appear consistently throughout the pages in your web. These borders can contain page banners and navigation bars. Page banners display the page title you gave each page when you created or saved it. Navigation bars are a row or column of hyperlinks to the other pages in the current web. FrontPage can automatically update shared borders and navigation bars, so the navigation structure of your web will always work correctly, even when you add, move, or delete pages from the web's structure.

In Lesson 1, you already completed the first step required for automatic navigation bars: creating the basic web structure in Navigation view. Because you have already done this, you'll now enable shared borders throughout your web.

(To create shared borders across a web
1. Click the Navigation icon on the Views bar to switch to Navigation view. 

2. Click the Folder List button to hide the Folder List in this view. 

3. On the Format menu, click Shared Borders.

FrontPage displays the Shared Borders dialog box. Here, you can specify where on your pages FrontPage should insert shared borders. Because your web structure has two levels of pages — the home page and the pages below it — you will use two kinds of shared borders and two kinds of navigation bars.

4. In the Shared Borders dialog box, make sure the All pages option is selected. 

5. For a horizontal shared border, select the Top check box and select the Include navigation buttons check box just below it. 

6. For a vertical shared border, select the Left check box and select the Include navigation buttons check box below it. 

7. Leave the Right and Bottom check boxes unchecked, and then click OK. 

FrontPage creates shared borders and default navigation bars for all the pages in the current web. You'll see what these look like when you return to Page view.

Next, you'll customize the appearance of the default navigation bars. Because they are shared across all pages in the current web, you can change their properties on any page and the change will be reflected across the entire web.

(To test navigation bar hyperlinks
1. In Navigation view, double-click the Home Page. 

2. Click the Folder List button to hide the Folder List in Page view. 

Note the changes FrontPage has made to the home page. It now contains a top and left shared border. The top border contains a page banner with the name of the current page, and the left border contains a list of navigational hyperlinks that look exactly like the ones you manually created at the beginning of this lesson.

In Page view, you can easily test hyperlinks that point to pages and files in your web.

3. Hold down CTRL and then click the first navigational hyperlink named Background on the left side of the page. 

FrontPage opens the page the hyperlink points to. On the Background page that is now open, shared borders and navigation bars have also been inserted. On this page, however, the links to the other pages are displayed in the top border, just under the page banner. This is because FrontPage uses the web structure you created in Navigation view to determine the level the current page is on.

By default, the top shared border points to pages on the same level as the current one, whereas the left border points to pages below the current one. In the next section, we'll change this default to another design.

(To customize navigation bars
1. On the Window menu, click index.htm. 

FrontPage brings the home page back into view.

2. In the top border of the home page, double-click the text that reads Edit the properties for this Navigation Bar to display hyperlinks here.

Double-clicking a navigation bar opens the Navigation Bar Properties dialog box. Here, you can customize the appearance of a navigation bar and the hyperlinks it creates.

Currently, the horizontal navigation bar is set to link to pages on the same level. Since the home page is on its own level in your navigation structure of your web, there are no other pages on the same level. FrontPage therefore doesn't show any navigation bars in this shared border.

For the Millennium Celebration Web, we want to have a horizontal navigation bar on the home page and vertical navigation bars on the other pages. To do this, we'll change the default setup of both navigation bars. You can make these changes on the current page and they'll be reflected throughout your web.

3. In the Navigation Bar Properties dialog box, click Child level, clear the check boxes for Home page and Parent page, and then click OK. 

FrontPage creates a navigation bar with hyperlinks to all the pages below the home page level.

4. Press HOME to deselect the navigation bar. 

Your page should now look like this:
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Note that the left navigation bar still contains the same set of hyperlinks as the top navigation bar. In the next steps, you'll remove the obvious redundancy, and format the left navigation bar so it is displayed only on the other pages that the home page points to.

5. In the left border of the home page, double-click the vertical navigation bar. 

6. In the Navigation Bar Properties dialog box, click Same level, select the Home page check box, and then click OK. 

FrontPage changes the navigation bar to the placeholder text that reads "Edit the properties for this Navigation Bar to display hyperlinks here." This text is only shown in Page view while you work; it will not appear in a Web browser.

By pointing the hyperlinks in this navigation bar to the same level as the home page, you are effectively removing the hyperlinks from the left border, because there are no pages on the same level as the home page. This also removes the redundancy between the horizontal and vertical navigation bars.

7. To save the home page, click Save on the File menu, or click the Save button on the toolbar. 

Your page should now look like this:
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8. On the Window menu, click background.htm. 

FrontPage brings the Background page back into view.

Note that the changes you've made on the home page to both the horizontal and vertical navigation bars are automatically reflected here, as well as on all the other pages in your web.
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Excluding pages from navigation bars   By default, all pages in your web's navigation structure are included in navigation bars. You can select pages to be excluded from your navigation bars by right-clicking the page in Navigation view and deselecting Included in Navigation Bars on the shortcut menu.
Applying a Theme
Although the addition of pictures, lists, forms, shared borders, and navigation bars has given the pages in the Millennium Celebration Web a more streamlined and organized look, you may wonder what to do about the rather bland appearance of black and blue text on a white background. After all, this web is about celebrating an event. You want the pages to look more lively and fun.

Imagine how time-consuming it would be if you had to design a color scheme for text and graphics, and create graphical page banners, navigation buttons, list bullets, and background textures for all the pages in your web. Now imagine how many more custom graphics you would need to create if you maintained more than one Web site and you didn't want any of your webs to look the same.

FrontPage includes more than 50 professionally designed themes with matching color schemes that you can apply to any or all pages in your web. A theme consists of design elements for bullets, fonts, pictures, navigation buttons, and other graphics. When applied, a theme gives pages, page banners, navigation bars, and other elements of a web an attractive and consistent appearance.

(To apply a theme to the Millennium Celebration Web
1. On the Window menu, click index.htm. 

FrontPage brings the home page back into view.

2. On the Format menu, click Theme. 

FrontPage displays the Themes dialog box. Here, you can select from a list of themes that FrontPage installed by default, or choose to install the complete set of themes from your FrontPage 2000 CD-ROM. You can make choices about the appearance of the theme, preview theme elements, and modify the selected theme.

3. Click on some of the different theme names in the scrolling list box. 

When you click the name of a theme, the Sample of Theme window shows a sample of the graphical elements that are contained in the selected theme. This way, you can first preview a theme before applying it to selected or all pages in your web.

Before applying a theme, you can select theme options that affect the appearance of the theme's components. For example, selecting Vivid colors applies brighter colors to text and graphics, selecting Active graphics animates certain theme components, and selecting Background picture applies a graphical background to the pages in your web. You can also choose to apply a theme as a cascading style sheet (Apply using CSS).

For the Millennium Celebration Web, you'll clear these defaults.

4. Under Apply theme to, make sure All pages is selected. 

5. In the list of installed themes, click Artsy. 

6. Clear the check boxes for Active graphics and Background picture, then click OK to apply the theme. 

Since this is the first time you're applying a theme to a web, FrontPage displays a message to let you know that applying a theme will overwrite some of the manual formatting you may have done on your pages.

We've purposely not included much manual design work in this tutorial, so you can acknowledge this message and proceed to apply the theme.

7. Click Yes to apply the theme. 

The theme named "Artsy" is applied to all the pages in your current web.

8. To save the home page, click Save on the File menu, or click the Save button on the toolbar. 

Your page should now look like this:
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As you can see, applying the theme has dramatically changed the appearance of the home page. The page banner and navigation buttons are no longer plain text; now they're colorful graphics. The page background has changed from white to black, which simulates the night sky that the millennium fireworks will appear in, and the font has changed color and is a little larger.

(Displaying graphical navigation buttons on all pages
1. On the Window menu, click background.htm. 

FrontPage brings the Background page back into view.

Note that the page has inherited its theme and theme elements from the home page, but the vertical navigation bar in the left border still shows plain text hyperlinks. By default, vertical navigation bars are displayed as plain text, so they look this way even after you apply a theme. You can easily change navigation bar settings even after a theme is applied.

2. In the left border of the Background page, double-click the vertical navigation bar. 

3. Under Orientation and appearance in the Navigation Bar Properties dialog box, click Buttons, and then click OK. 

4. Click anywhere on the page to deselect the navigation bar. 

FrontPage changes the navigation formatting and uses the graphical buttons included with the theme. The web now has an attractive and professional look.

5. To save the page, click Save on the File menu, or click the Save button on the toolbar.
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Some themes contain animations   When you apply a theme, you can select Active graphics to enable page banner animations and navigation bar rollover effects, if the theme contains such elements. The theme sample will not show you what these effects look like. To see a theme's active graphics effects, apply the theme and then display the page in the Preview tab, or click the Preview in Browser command on the File menu.
Modifying a Theme
Although the page banner of this theme looks nice, something directly related to the subject matter of the Millennium Celebration Web might fit better. We've prepared a custom page banner that you will use to modify the current theme with. This custom banner provides a colorful fireworks backdrop for the page banner text.

(To modify a theme
1. On the Window menu, click index.htm. 

FrontPage brings the home page back into view.

2. On the Format menu, click Theme. 

FrontPage displays the Themes dialog box. In the list of themes, the Artsy theme is now the default theme because it has been applied to the current web.

3. In the Themes dialog box, make sure All Pages is selected. 

4. Next, click Modify. 

5. Under the question What would you like to modify? click Graphics. 

FrontPage displays the Modify Theme dialog box. Here, you can supply custom graphics for various theme elements such as page banners, navigation buttons, background pictures, and other elements. FrontPage superimposes text over these graphics, so there is no need to change graphics when you change the names of your pages, or add or remove pages.

For this example, we will change the graphical page banner on which FrontPage places the titles of the pages in the Millennium Celebration Web.

6. In the Item list, click Banner. 

7. On the Picture tab, click the Browse button below the file name of the current banner graphic. 

FrontPage displays the Select Picture dialog box and shows the current pictures in your current web. Since the graphical banner we want to use isn't part of the web yet, you will search your file system for it.

8. In the Select Picture dialog box, click the Select File button. 

FrontPage displays the Select File dialog box.

9. Navigate to the folder named Program Files\Microsoft Office\Office\Tutorial by double-clicking each folder in this path until the Look in box displays the Tutorial folder. 

If you downloaded the tutorial files from www.microsoft.com, navigate to the folder named Fptutor\Samples, or to the folder where you placed the files.

10. Double-click the file 2000ban. 

FrontPage replaces the current page banner graphic with the custom graphic.

11. Click OK in the Modify Theme dialog box, and then click OK in the Themes dialog box. 

FrontPage displays a message asking you whether you want to save changes to the current theme.

12. Click Yes. Enter Millennium as the title of the modified theme, and then click OK. 

FrontPage saves the modified theme and applies the new banner to all pages.

13. To save the page, click Save on the File menu, or click the Save button on the toolbar. 

Your page should now look like this:
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Making your own themes   For this tutorial, we've provided only a custom page banner to help show you how easy it is to customize existing themes. To create your own designs, repeat the steps in the previous procedure to customize other theme elements with your own custom graphics.
Congratulations, the Millennium Celebration Web is almost finished! To make sure everything will look great on the World Wide Web, you'll now preview the web in your Web browser.

Previewing the Millennium Celebration Web

Although Page view shows you the appearance of your Web pages as closely as possible to how they will appear in a Web browser, it displays some page elements and placeholders differently to help you while you design the page. By previewing a page or your entire site in a Web browser before you publish the web, you can make sure that everything looks the way you want it to.

(To preview the current web in a Web browser
1. On the File menu, click Preview in Browser. 

FrontPage displays the Preview in Browser dialog box. Here, you can select from the installed Web browsers on your computer, add Web browsers you installed after installing FrontPage, and select the Web browser window size in which you want to preview your web.

The Preview in Browser feature loads the current page in your Web browser, so you can see exactly how the page will appear in your favorite Web browser before you publish your web. You must have at least one Web browser installed on your system for this feature to work.

2. In the Preview in Browser dialog box, click Microsoft Internet Explorer, and then click Preview. 

FrontPage launches the Web browser and opens the home page.

Your screen should now look like this:
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Note that all placeholder text and formatting marks are hidden from view (for example, the empty vertical navigation bar on the left side of the home page does not appear).

3. Click the buttons on the navigation bar to preview some of the other pages. 

Note the vertical navigation bar on the pages below the home page. On the Destinations page, scroll down to the feedback form you added to the page. You can enter text in the fields, but the form won't actually work until you publish the Millennium Celebration Web to a Web server. 

On the Photo Album page, click the picture thumbnails to test the hyperlinks to the full-size pictures. Use your Web browser's Back button to return to the Photo Album page. Finally, on the Links page, note the dynamic animation of the paragraph heading that reads "Links to My Favorite Sites."

4. Close your Web browser when you have finished previewing the Millennium Celebration Web. 
Organizing the Files in your Web

Now that your web contains several pages and files, you will use Folders view to organize them. Similar to Windows Explorer, Folders view lets you manage the files and folders in your web. You can safely rearrange the pages and files in your web without breaking hyperlinks, page banner titles, or navigation button labels.

In Folders view, FrontPage displays a hierarchical list of the folders in your web on the left side of the screen. Clicking on a folder in the Folder List displays its contents on the right side — the Contents pane.
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In the following steps, you will move all the picture files in the Millennium Celebration Web to the Images folder FrontPage created as part of the web.

If you were to use Windows Explorer or another file manager to move pages and files from one folder to another, you would break the hyperlinks between your pages and page elements. However, when you maintain your web in Folders view, FrontPage keeps every page and hyperlink in your web updated to keep track of the new locations of files and folders that have been moved.

(To move picture files to the Images folder
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Folders icon
1. On the Views bar, click the Folders icon. 

FrontPage switches to Folders view.

2. In the Folder List pane, click the top-level folder labeled C:\My Documents\My Webs\Millennium. 

3. In the Contents pane, click the Type column label. 

Clicking on a column label sorts the files in the Contents pane by that criteria. The first time you click a column label, the list is sorted in ascending order; when you click it a second time, it is sorted in descending order.

The list of files is now grouped by file type, with all GIF picture files at the top of the list, followed by HTM files (pages) in the middle, and all JPG pictures at the bottom of the list.

4. In the Contents pane, click the first picture file (2000.gif) at the top of the list to select it. 

5. Next, while holding down SHIFT, click the last GIF picture file in the list (sanfran.gif). 
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In Folders view, FrontPage supports all standard Windows selection shortcuts, such as SHIFT+CLICK for selecting ranges of files, and CTRL+CLICK for selecting noncontiguous files. 

6. Click and hold the right mouse button while the pointer is over any of the selected GIF file icons. 

7. Next, drag the mouse pointer over to the Images folder in the Folder List pane. 
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8. When the Images folder is selected, release the mouse button and click Move Here on the shortcut menu. 

FrontPage displays the Rename dialog box while it is moving the selected GIF image files to the Images folder because it is automatically updating all hyperlinks to these files in the current web.

9. Repeat steps 4 through 8 with all JPG picture files, starting with Firewks1.jpg and ending with Firewks4_small.jpg. 

10. In the Contents pane, click the Name column label to arrange the remaining list of folders and files by their name again. 

You've successfully grouped all picture files in the Images folder.

When you work with your own webs, you can group sound files, movie clips, and other types of files in their own folders. You can create new folders in Folders view as needed and delete the ones you no longer need.

(To create a new folder
1. In the Folder List, click the folder in which you want to create a new subfolder. 

Folders can be expanded and collapsed in the Folder List to bring their subfolders into view. Click the plus (+) and minus (-) signs next to a folder's name to display or hide its subfolders.

2. On the File menu, point to New and then click Folder. 

FrontPage creates a new folder with a temporary name.

3. When the folder's temporary name (New_Folder) is selected, type a new name for the folder, then press ENTER. 

The new folder is renamed, and you can now drag and drop files into it.

For this tutorial, we don't need the extra folder you just created, so you will delete it before we get ready to publish the web.

4. In the Folder List, right-click the folder you just created. 

5. On the shortcut menu, click Delete. 

6. In the Confirm Delete dialog box, click Yes. 

FrontPage removes the folder from the web.

Generating a Site Summary

Reports view is an important tool that shows you the overall health and condition of your web before you publish it to the World Wide Web. You can generate custom reports about your web in up to 14 categories.

(To generate a Site Summary report
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Reports icon
· On the Views bar, click the Reports icon. 

FrontPage switches to Reports view. The default report is the Site Summary. This report shows you the overall statistics of the pages and files in the Millennium Celebration Web. Here are some important ones to look at before you publish your web:

· All files: you currently have 21 files in your web, totaling approximately 275K in size. This is the amount of space you'll need to have available on the Web server that will host your web. 

· Slow pages: this category shows pages that are slow to download at the targeted download speed. Because you created small thumbnails of the large fireworks pictures in your online Photo Album, your web currently doesn't have any slow pages for you to worry about. 

· Broken hyperlinks: If any broken hyperlinks are reported here, double-click the Broken hyperlinks row to view details about this category. FrontPage lists unverified hyperlinks, such as the external hyperlinks on your Links page, and links that are broken and do not work. 

· You can verify that a hyperlink still points to an active Web site by right-clicking the link in Reports view and choosing Verify from the shortcut menu. To fix a broken hyperlink, you must open the page it is on and repair the URL the hyperlink points to. 
Spell Checking

While you can use automatic background spell-checking and per-page spell-checking in Page view, using the Spelling command in any web view lets you check the spelling of all (or selected) pages across the current web.

You can check the spelling of page elements that can be edited directly on the page. Other text, such as page titles in page banners or text contained in FrontPage-based components, are not included in the spelling check.

(To check spelling in the current web
1. On the Tools menu, click Spelling. 

FrontPage displays the Spelling dialog box. Here, you can specify whether FrontPage should check the spelling of selected pages only, or of the entire web.

2. In the Spelling dialog box, click Entire web, and then select the Add a task for each page with misspellings check box. 

FrontPage will add a task to the Tasks list for each page on which misspelled text is found. You will learn about Tasks view in the next section.

3. In the Spelling dialog box, click Start to begin the spelling check. 

FrontPage expands the Spelling dialog box to display the progress of the spelling check.

When the operation has been completed, FrontPage displays the misspelled words and the number of tasks that were added to the Tasks list in Tasks view.

4. Click Cancel to dismiss the Spelling dialog box. 

The spelling check is complete, but the corrections will not be made until you complete the tasks in the Tasks list.

Replacing Text on Pages

The Replace command makes it easy to find and replace content on selected pages or all pages in the current web. While you can use the command to replace text on the current page in Page view, using it in any web view lets you replace text in all (or selected) pages across the current web.

You can replace any text that can be edited directly on the page. Other text, such as page titles in page banners or text contained in FrontPage-based components, cannot be automatically replaced.

(To replace text on all pages in the current web
1. On the Edit menu, click Replace.

FrontPage displays the Replace dialog box. Here, you enter the string of text to be found and what you want to replace it with. You can choose to replace text on all pages in the current web, or on selected pages only.

2. In the Replace dialog box, type Welcome to my Web site in the Find what box. 

3. In the Replace with box, type Thanks for visiting my Web site. 

4. Click the Match case check box, and then click Find in Web. 

FrontPage expands the Replace dialog box to display the progress of the search. The search text you want to replace is found on the home page, Index.htm.

When the operation has been completed, FrontPage displays the number of occurrences it has found.

5. Click Add Task in the Replace dialog box. 

6. Click Cancel to dismiss the Replace dialog box. 

The replacement search is complete, but the actual replacement will not occur until you complete the task in Tasks view.

Completing Web Tasks

Tasks view displays the list of all outstanding tasks associated with the current web. Tasks are items that need your attention before you publish the web.

In the previous exercises, you added tasks to a list when you deferred certain actions. For example, when you checked the spelling of the pages in your web, you chose to add a new task for each page containing misspellings. By adding tasks to the list, you can complete such corrections all at once.

If you are working in a web development environment or on an intranet, Tasks view makes it easy to track web tasks and assign them to other authors who work on the same web.

(To complete tasks in Tasks view
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Tasks icon
1. On the Views bar, click the Tasks icon. 

FrontPage displays the Tasks list.

2. Double-click the first task on the list, labeled "Fix misspelled words."

FrontPage displays the Task Details dialog box. Here, you can see details about the task you're selected. You can set the priority of the task, assign it to another author on your network, or complete the task and remove it from the list.

3. In the Task Details dialog box, click Start Task. 

FrontPage switches to Page view and opens the page containing the misspelled words.

4. In the Spelling dialog box, click Ignore when FrontPage questions the name "Balleny." 

5. Click Add to add "Cheops," the name of the Egyptian king, to your dictionary. 

FrontPage shares custom dictionaries with other Microsoft Office applications, so you don't need to add custom words in each application separately.

When you add verified words to your dictionary, they will not be questioned again.

6. Click OK. 

FrontPage completes the spelling check. If you want to, you can now return to Tasks view and mark this task as completed.

Although it is not required that you complete every task before publishing your web, it is a good idea to review this list when you are finished making changes to the web. Tasks view helps you manage webs by flagging important reminders for you.

Publishing the Millennium Celebration Web

When you publish your web on the World Wide Web — or your company intranet — FrontPage automatically verifies your hyperlinks, the addresses of your pages, and the paths to your files.
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If you do not want to publish the Millennium Celebration Web to your Web server, read this procedure for reference only, without actually completing the steps. 

(To publish the Millennium Celebration Web
1. Close all open pages in Page view.
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Publish Web button
2. On the File menu, click Publish Web, or click the Publish Web button on the toolbar. 

FrontPage displays the Publish Web dialog box. Here, you specify the location on the World Wide Web or your corporate intranet to which you want to publish your web. Your Internet service provider can tell you this information.

You need Internet access through an Internet service provider before you can publish your web to the World Wide Web. If you want to sign on with a Web Presence Provider that can host FrontPage-enabled webs, click the WPPs button in the Publish Web dialog box.

[image: image67.png]‘Specily the location o publish your web to:

it /7example. microsoft com/~mywe{ - Browse.

8 WPP'...| Cick here f you donit have a web presence provider

Options = Publsh Cancel





3. In the Publish Web dialog box, enter the URL of your target Web server, (such as http://example.microsoft.com/~myweb), and then click Publish. 

FrontPage publishes the current web from your computer to the World Wide Web or intranet Web server you specified.
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One-button publishing   After you publish a web for the first time, you can bypass the Publish Web dialog box by using the Publish Web button on the toolbar. This quickly publishes any updates you've made to your pages without having to provide any information about the web's location. To again display the Publish Web dialog box, use the Publish Web command on the File menu instead of the toolbar button.
If FrontPage detects that you are publishing to a Web server that does not support the FrontPage Server Extensions, it will publish the current web via the FTP file transfer protocol.

If the Web server to which you are publishing your webs has the FrontPage Server Extensions installed, your webs will have full functionality of FrontPage-based components and Web scripts that you may have inserted on your pages.

Publishing webs to a Web server that does not have the FrontPage Server Extensions installed may disable some functionality contained on your pages, such as the feedback form you added. FrontPage will display informational messages during the publication process to alert you of such conditions.

During the publishing process, FrontPage displays a progress bar to indicate how much time is required to transfer your web to the target Web server.
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The speed at which FrontPage publishes your web depends on your connection speed, as well as the number and complexity of the pages and files in your web.
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Excluding pages from being published   When you publish a web, all of its pages and files are published by default. To exclude pages or files from being published, right-click the page or file in a web view, click Properties on the shortcut menu, and select the Exclude this file when publishing the rest of the web check box on the Workgroup tab.
When FrontPage has successfully published your web, it provides a hyperlink to your new Web site in the confirmation dialog box. Click the link to open the published Web site in your Web browser.

Finishing Lesson 2

Congratulations, you have successfully completed the FrontPage Tutorial. You are now ready to create and publish your very own FrontPage-based webs.

